System Requirements

Operating System

Jewelry Designer Manager Premier is compatible on both Mac and Windows computers.

Mac OSX

JDM Premier Version 6.00:  OSX v10.11 and up.  (El Capitan, Sierra, High Sierra and Mojave).

JDM Premier Version 1.00 – 5.00:  OSX v10.7 – v10.10  (Lion, Mountain Lion, Mavericks, Yosemite, El Capitan, and Sierra)

Windows

Microsoft Windows 7, 8 or 10.

 

Java

JDM Premier Versions 6.00 do not require Java.

Previous versions of JDM (Versions 1.00 – 5.00) require that Java be installed to use some of the feature in JDM Premier such as importing data from JDM Pro and Deluxe and backing up and restoring data.  Please install or update to the most current version of Java 8 (use 32-bit version even if your computer is 64-bit). This is a free download from www.Java.com from Oracle. To check to see if you have Java on your machine and the most up-to-date version click here:  http://www.java.com/en/download/installed8.jsp

 

Java Setup

When installing Java you have the option to install the Search App by Ask.  Please de-select these items if you do not want Ask.com to be the default browser home page and search provider.

 

Pin It on Pinterest